
Premier+™ Embroidery Master Class 
Quarter 2 2016: 
Exploring Font Create 

by Soni Grint

Use Premier+ Font Create to adjust existing
fonts, create your own font and even create
your own SuperDesigns.  

Adjust an existing font for Puffy Foam
1. Open Premier+™ Embroidery Extra.

2. Quick Link to Accessories / Premier+™ Font
Create.

3. In the Create or Edit Font window choose 
Create a new, type Name as Miami Foam 30-60
mm, Joining Point at Baseline, Minimum Size = 
30 mm, Maximum Size = 60 mm.

4. Click OK.

5. Go to the View tab and 
hide the background image.

6. Ensure the grid size is 10
mm.

7. Go to the Home tab and click on Insert
Lettering.

8. Choose the Category Retro, Font Miami 12 – 40 mm.

9. Click the upper case A.

10. Click Insert then click Cancel.
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11. Move the letter A to the red baseline.

12. Change the size of the letter A until the width is 20 mm and the height is 30 
mm.

Now let's change the font to make it a Puffy Foam font.

For a foam font, the stitching at the end of a satin stitch column must “cut” the 
puffy foam.  

There are different ways to accomplish this.

• Turn the stitching so the foam is perforated.

• Add another row of stitching under the original to perforate the foam.

13. Go to the View tab.  

• Notice the satin stitches at the bottom of the A.

14. Click Object View.

15. In the Film strip, click the 3rd object (satin column).  

16. Right Click in the work area for the nodes to show on screen.

17. Move the bottom left square node (1) to the right, on top of
the bottom right square node.

18. Hold the CTRL key on the keyboard and move the left round node (2) to 
replace the bottom square node.

19. Click the 2D View and see how the satin has changed angle to perforate the 
foam.
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20. Go back to Object View.

21. Click object 14 in the Film Strip.

22. Click the Home tab.

23. Click Insert Points.

24. Click once between the two bottom points on the
left side of the object.

• Both points for a satin column are place
automatically.

25. Right Click to end the tool.

26. Move the right bottom square node to the left, on top of the other square 
node.

27. Hold the CTRL key and move the right round node to replace the bottom 
square node.

28. Click Design Player to see how the A will be stitched.

29. Click Play.  Click Fast Forward to speed the playback.

30. Click Cancel.

31. Click object 9 in the Film Strip.

32. On the Precise Create tab, choose Running Stitch.

33. Click Create Area or Line.

34. Left click on the Yellow / Blue star.

• Notice when you move the mouse over the star
the pointer changes to a dash.

• This means you are connecting with the
previous object.

35. Continue clicking to the top left part of the letter A.

36. Right click to end the tool.
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37. Choose Satin Column. 

38. Left click, starting on the yellow star, to create a satin column “cap” that will 
cut the puffy foam.

• Left click back and forth to create the satin column.

39. Right click to end the tool.

40. Click on object 12 in the Film Strip.

• There is a line between object 11 and 12 in the Film Strip.

• The line represents a jump stitch in the design.

41. Move the start point of the line to the end of the satin column cap.

• Remember when the mouse turns to a dash, the objects will connect.

42. Adjust the other nodes of the line so the movement is smooth.

• See that the line between the objects went away.

43. Click the Design Player and play the design.

44. Click Save in the Design Panel to save the letter A in your font.

45. Click on the upper case B in the digitized characters area.

46. Go to the Home tab.

47. Click Insert Lettering.

48. Choose the Category Retro, Font Miami 12 – 40 mm.

49. Click the upper case B.

50. Click Insert and then click Cancel.

51. Move the letter B to the red baseline.

52. Change the size of the letter B until the width is 20 mm and the height is 30 
mm.

• Think about where to turn the stitching or add a cap.

53. Click object 10 in the Film Strip.
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54. Click Insert Points.

55. Left click to place a new control line to the right of
the bottom left part of the B.

56. Right click to end the tool.

Move the points the same as the letter A.

57. Move node 1 to the node just above.

58. Move node 2 to replace the previous
node.  Hold the CTRL key to make a
point (square node).

59. Click on object 14 in the film strip.

60. Adjust the nodes to create the angled stitches.  

61. Click on object 16 in the Film Strip.

62. Go the the Precise Create tab.

63. Click Single Stitch.

64. Click two single stitches to move you to just inside and the
top of the curve of the B.

65. Click Satin Column.

66. Add a Satin Column cap starting with the yellow star and ending with the 
blue star.

67. Right click to end the tool.

68. Click Design Player to see how the B will stitch.

69. Click Save in the Design Panel to save the letter B.

70. Continue with the other letters in the Alphabet.

• If all letters are not needed, only create those that will be used.
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71. Quick Link back to Premier+™ Extra.

72. Go to the Letter tab.

73. Scroll to My Fonts and choose Miami Foam 30 – 60 mm.

74.  Type AB in the letter area.

75. Click Apply.

• The new letters now react like any other font within the Premier+™ 
program.

Adjust any font to your preferences

Create an Original Font

1. Quick Link back to Premier+™ Font Create.

2. In the Create or Edit Font Window choose Create a new, type name as Master 
Class, joining point at Baseline, Minimum size = 15 mm and Maximum size = 30 
mm.

There are 3 joining point styles for fonts.

• Baseline is the simplest style of font.

◦ Choose Trim connection when using these fonts in Premier+ 
Embroidery.

◦ Start a baseline font on the left and end on the right as close to the red
baseline as possible.

• Nearest point is a special type of font.  Use
these fonts to avoid the need to trim
between letters.

◦ Choose Running connection when
using these fonts in Premier+
Embroidery.

◦ Each letter in the font must be digitized
4 times with a different starting and
stopping point.

• Continuous fonts give a flowing effect for
script fonts.
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◦ All lower case letters in a continuous font should start and end at the 
same height above the baseline so the letter flow nicely. 

3. Click OK.

4. On the Design Panel, click Font Background. 

5. Choose Font DejaVu Sans, Style Bold, Scale % = 
100.

6. Click OK.

7. Click Move Guidelines.

8. Click and drag one guideline to the top of the letter A.

9. Go to the View tab and change to Object View.

10. Zoom in as necessary.

11. Go to the Precise Create tab.

Now decide how the font will look.  Satin vs Fill.  Feathered corners vs overlapped.

12. Choose Running Stitch.

13. Click Create Area or Line.

14. Click a line to the upper left part of the A cross.  

15. Right click twice to end the tool.

16. Click Satin Column.

17. Left click the first point of the satin column at the pink star.

18. Move the mouse just below the first and place another point.

Page | 7 

© 2016 KSIN Luxembourg II, S.a.r.l . PREMIER+ is a trademark of KSIN Luxembourg II, S.ar.l.. All rights reserved.



19. Move the mouse to the top center of the
cross and click.

20. Move to the bottom center of the cross and
click.

21. Move to the top left and click.

22. Then to the bottom left and click.

23. Right click twice to end.

24. Adjust points as necessary.

• Move the left and right points into the legs of the A.

• This provides compensation so there will not be a gap between the cross 
and the legs.

25. Click Create Area or Line (Ensure Running
Stitch is active).

26. Left click, starting at the pink star, around
the A just inside the image.

• Hold the CTRL key to create a point.

27. End the points at the bottom left part of
the left leg.

• Edge walk underlay will keep the satin
stitching flat and stop tunneling of
the letter.

28. Right click twice to end the tool.

29. Choose Satin Column.

30. Starting at the pink star on the left leg, left click.

31. Move directly across the image from the first point and left click.

• Hold the CRTL key to keep the satin straight on the edge.

• The angle of the line created will be the angle of the stitch.

32. Move up the leg about half way and left click on the left side of the image.
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33. Move across the image to the right of the previous point and left click.

34. At the top of the letter A,
use 5 control lines to create a
nice feather at the point
inside the A.

• Keep the points and
lines even to make the
satin even.

35. Right click twice to end the
tool.

36. Click Single Stitch.

37.  Click on the bottom right
of the right leg of the A.

• The stitch for the A now starts on the left and ends on the right.

38. Click Life View to see how your letter will look.

39. Click Save the Current Font.

• The A is now a digitized character.

40. Click the letter B in the digitized character area.

• The B image is now in the work area with the
guidelines still in place.

• The letter B will have the same look as the A.

41. On the Precise Create tab, ensure Running Stitch is active, and choose Create 
Area or Line.

42. Left click just inside of the B image to create Edge Walk underlay.

• Start at the bottom left of the B.

43. Click near the outside of the image until you get to the
cross in the B.

44. Right click twice to end the tool.

45. Click Feathered Satin.
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46. Add a small feathered satin column at the end of the B cross.

47. Right click twice to end the tool.

48. With the feathered satin column highlighted, right click and change density 
to 5, feathered sides both and stitch length to 3 mm.

49. Click OK.

50. Click Create Area or Line. 

51. Finish the underlay by starting at the pink star and left
clicking to the bottom of the letter B just before the curve of
the B.

52. Starting at the pink star, Single Stitch to the outside of the image.

53. Choose Satin Column.

54. Starting at the pink star, place points across the image
ending around the top curve of the B.

• Use 3 control lines at each corner to make an even
feather at each corner.

• Hold the CTRL key when placing the control lines at
the corner.

55. Right click twice to end the tool.

56. Click Create Area or Line. 

57. Running stitch to the bottom of the B cross.

58. Right click twice to end the tool.

59. Choose Satin Column.

60. Starting with the pink star, left click across the image to finish the letter B.

• When placing the points across the bottom curve of the B, ensure you are 
“covering up” the previous stitching so there will not be a gap.

• At the end, overlap the points to make sure there is not a gap.
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61. Right click twice to end the tool.

62. Adjust points as necessary to finish your letter.

63. Click Life View and see how your letter will stitch.

64. Click Save the Current Font.

Continue to digitize letters for the Font.

65. Go to the View tab and change the grid size to 5 mm.

66. To create a space for the font, click on the upper left
character in the Digitized Characters area.

• The width of the A will be the width of the space.

• The height of the A will be the height of the space.

67. Click Snap to Grid on the Design Panel.

68. Click the Navigation tool on the Design Panel.

69. Click 5 mm to the right on the baseline.

70. Click 15 mm directly up from the first click (to the guideline)

71. Click 5 mm to the right on the guideline.

72. Click 15 mm down to the baseline.

73. Click 5 mm to the right on the baseline.

• 6 objects will create the space.

• The object should look like a post.

• By creating the space like this, the
space distance in ensured to be
consistent.

• The actual navigation lines do not show color, orange was added so the 
post could be seen.

74. Click Save.

• The navigation tool is movement and should be used for spaces.

Make your own fonts for any occasion.
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Create a Super Design Set

1. Quick Link to Premier+™

Create.

2. Choose Load a Vector Picture as Objects into the Draw Window.

3. Click Next.

4. Click Load a Picture. 

5. Load the half butterfly for this Master Class.

6. Click OK. 

7. Click Next.

8. Choose Fit Design to Hoop and Change Hoop to Hoop Group Universal, 
Hoop Size 100 mm x 100 mm, Orientation Natural and click OK.

9. Click Finish.

10. Click the Precise Create tab.

11. Right click the color bar in the Film Strip.

12. Choose Properties and change the color to Yellow.

13. Click OK.

14. Click Satin Column. 

15. Starting where the bottom wing touches the body, 
place points back and forth across the bottom wing
until the satin column touches the top wing.

16. Right Click twice to end the tool.

17. Ensure that Object 2, Satin Column, is highlighted.
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18. Click the bottom of the Color Change icon.

19. Choose the Quick Color Orange.

20. Click the top of the Pattern Fill icon to turn it off, click the 
bottom of the Satin Line to change to Running Stitch.

21. Click Create Area or Line. 

22. Click around the top wing ending at the inside curl of
the wing.

23. Right click twice to end the tool.

24. Click Satin Column. 

25. Starting at the pink star, click back and forth across the top wing, ending at 
the body.

• Cover the previous stitching from the bottom wing.

• Adjust points after you finish the wing.

• If needed go to the Home tab and Insert Points.

26. Click the bottom of the Color Change icon and choose Red.

27. Choose Satin Column.

28. Starting at the bottom of the body detail, click a column back and forth 
across the detail to the top of the detail just into the head.

29. Right click twice to end the tool.

30. Click Single Stitch.

31. Click the top right side of the body.

32. Click the bottom of the Running Stitch icon and
change to Satin Line.

33. Click Create Area or Line.

34. Starting with the pink star, click around the body.

35. Right click twice to end the tool.
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36. With the body highlighted, right click in the work area and change the satin 
line to 3 mm.  Click OK.

37. Single Stitch to the bottom of the head of the butterfly.

38. Click on the top of the Pattern Fill to select it and click on
the top of the Satin Line to deselect it.

39. Click Create Area or Line.

40. Starting with the pink star, click around the head.

41. Right click twice to end the tool.

42. With the head highlighted, right click in the work area and change the fill 
pattern to 239.  Adjust the angle to 60.  Click OK.

43. Adjust the body and head points as desired.

44. With Object 11 highlighted (the head), click on the bottom of the Color 
Change icon and choose dark blue.

45. Click on the top of Pattern Fill to deselect the
fill and click on the bottom of the Satin Line and
choose Triple Stitch to select it.

46. Click Create Area or Line.

47. Click a line to create an eye for the butterfly
and continue up the front antenna.

48. Right click twice to end the tool.

49.  Click on the bottom of Triple Stitch and change to Running Stitch.

50. Click Create Area or Line.

51. Click back down the front antenna starting with the pink star.

52. Continue clicking the back antenna to the tip.

53. Right Click twice to end the tool.
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54. Click the bottom of the Running Stitch icon and change to Triple Stitch.

55. Click Create Area or Line.

56. Starting at the pink star, click back
down the back antenna to the top of the
head.

57. Make any adjustments as necessary.

58. Go to File and Save As Half
Butterfly.edo.

59. Quick Link to Premier+™ Font Create.

60. Choose File as SuperDesign Set, Create a New,
Name as Master Butterflies with Minimum Size = 
50 mm, Maximum Size = 100 mm.

61. Click OK.

62. Go to the View tab and adjust the
Background to minimum.

63. Click on the Home tab and click Insert. 

64. Click on Half Butterfly.edo.

65. Move the bottom of the butterfly to the
baseline.

66. On the Font page, click Save. 

67. Click on the next square in the Digitized Characters area.

68. Click on the Home tab and click Insert.

69. Click on Butterfly.edo.

70. Move the butterfly to the baseline.
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71.  Click on Universal Properties. 

• The first page allows change in all the objects and colors in
the whole Super Design set.

72. Click Next.

73. Under Allow Editable, place a check next to Satin
Line, Pattern Fill and Satin Column.

• This allows the end user to change these
objects after a SuperDesign is chosen in
Premier+ Embroidery.

74. Click Finish.

75. Click Save.

76. Quick Link back to Premier+™ Embroidery.

77. Go to the SuperDesign tab.

78. Click on My SuperDesigns and find Master Butterflies.

79. Choose the half butterfly and click Apply. 

• Ensure the half butterfly is selected.

80. Right click.

• Notice there are choices to change the Satin Line,
Pattern Fill and Satin Column.

81. Left Click to close the pop up window.

Have fun creating your own SuperDesign sets.
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